Jump to content


Photo

Ford Ka Dry Bush On Front End


  • Please log in to reply
3 replies to this topic

#1 Chopped

Chopped

    Settling In Well

  • New Member
  • PipPipPip
  • 39 posts
  • Name: Howard
  • Ford Model: Ford KA Sprint--53 plate
  • Year: 2003
  • Location: Somerset

Posted 26 July 2010 - 01:34 PM

hi there i have a 53 plate ford ka with what sounds like a dry bush on the front end someware,,sort of sounds creaky and dry sound,checked the coil springs they are fine and there is no leakage,,seems to be passenger side but hard to tell
could it be the bush on top of the suspension,,
its hard to pin point when driving :((
it drives fine and does not pull to one side or the other
it does it on straight and cornering driving
just wondering if anybody has had similer problem ???

the cars done 60,000 miles

many thanks in advanced,,,,

Chopped

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 delboy

delboy

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 560 posts
  • Name: martin
  • Ford Model: c-max ghia 1.8 petrol /ka 1.2 mk2
  • Year: 2004
  • Location: Somerset

Posted 26 July 2010 - 05:39 PM

i would 1st try bouncing the car on each corner
it maybe the drop link with is easy to do & cheap
about 7.00 per side.
ask a friend to hold the drop link (it is a bar that bolts from the front suspension to the
anti roll bar) and then bounce the car so find if there is any play in them. do each side
you may need to use an angle grinder to cut off the drop link as they tend to rust on.

also check the anti roll bar. hold the bar from the front or the car(you dont need to jack car up just reach under) & pull it back & forth.
if there is any play you need to replace the rubbers on it.
cost about 7.00 a pair.

www.buypartsby.co.uk

that's where i get my parts from if it's any help

keep us posted on what the problem is m8

also if it's not either of what i said give the under side rubbers etc a good spray with wd40

#3 Chopped

Chopped

    Settling In Well

  • New Member
  • PipPipPip
  • 39 posts
  • Name: Howard
  • Ford Model: Ford KA Sprint--53 plate
  • Year: 2003
  • Location: Somerset

Posted 26 July 2010 - 06:20 PM

i would 1st try bouncing the car on each corner
it maybe the drop link with is easy to do & cheap
about 7.00 per side.
ask a friend to hold the drop link (it is a bar that bolts from the front suspension to the
anti roll bar) and then bounce the car so find if there is any play in them. do each side
you may need to use an angle grinder to cut off the drop link as they tend to rust on.

also check the anti roll bar. hold the bar from the front or the car(you dont need to jack car up just reach under) & pull it back & forth.
if there is any play you need to replace the rubbers on it.
cost about 7.00 a pair.

www.buypartsby.co.uk

that's where i get my parts from if it's any help

keep us posted on what the problem is m8

also if it's not either of what i said give the under side rubbers etc a good spray with wd40


ok thanks delboy ,, is it a mot issue do you think,,
hope its not dangerous :(

thanks again

#4 jmurray01

jmurray01

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 793 posts
  • Name: Jamie
  • Ford Model: None at present
  • Year: Non
  • Location: Moray

Posted 27 July 2010 - 07:16 PM

Probably the anti-roll bar linkage! B)


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users