Jump to content


Photo

Ford Focus


  • Please log in to reply
1 reply to this topic

#1 lol

lol

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: focus

Posted 01 August 2010 - 10:38 PM

hello i,m lawrence from the north east i,m new to this forum,i have a 2006 56reg ford focus sport 1.8tdci,i am asking members if they can help me with a problem,i have just had a new turbo and inlet hose both fitted,my problem now is it wont rev beyond 2250 and is kicking a lot of black smoke out, my initial thought was the airflow meter, any help please would be appreciated.

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 jonboy01

jonboy01

    Settling In Well

  • New Member
  • PipPipPip
  • 54 posts
  • Ford Model: focus 1.6 lx

Posted 03 August 2010 - 02:04 PM

hello i,m lawrence from the north east i,m new to this forum,i have a 2006 56reg ford focus sport 1.8tdci,i am asking members if they can help me with a problem,i have just had a new turbo and inlet hose both fitted,my problem now is it wont rev beyond 2250 and is kicking a lot of black smoke out, my initial thought was the airflow meter, any help please would be appreciated.

not too sure if its relevant lawrence, but when my friends hose went on his tdci mondeo it showed the same symptons as yours are showing now..

have you checked all the other hoses for splits and is it possible that any oil was left behind in there from the previous repairs?

just a thought but i would check the hoses first.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users