Jump to content


Photo

Please Help Coil Light


  • Please log in to reply
2 replies to this topic

#1 roff

roff

    Newbie

  • Budding Enthusiast
  • Pip
  • 6 posts
  • Name: Karl
  • Ford Model: smax2.0 tdci
  • Year: 2008
  • Location: Newport

Posted 02 August 2010 - 07:43 AM

130 bhp tddci mondeo estate 03 plate.
When ever I tow a caravan I have the problem that when going up long inclines on the motorway or when accelerating hard and long the car will jurk and the coil light will come on. Sometimes going into limp mode. The usual thing pull over turn the engine off and back on its ok.
Another thing which may be linked. That when coasting (foot off the accelerator) and then touch the accelerator at around 40mph the car jerks.
MPG when towing is 32 and when not towing around the 50 MPG mark.
Please help worried about going to a garage and end up spending 500 and still have the fault as mentioned on numerous threads.

Any ideas would be appreciated

Cheers :)

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 CAR PARTS EXPRESS

CAR PARTS EXPRESS

    Authorised Trader

  • New Member
  • PipPipPipPip
  • 448 posts
  • Ford Model: mondeo

Posted 02 August 2010 - 08:14 AM

hi mate, you need to get it on diagnostics and have codes read to see whats going on...possible causes : injectors, pump, egr, turbo issue (vac valves) sounds like injectors though as more fuelling needed when towing up hill.

#3 brianfixit

brianfixit

    Newbie

  • New Member
  • Pip
  • 9 posts
  • Ford Model: mondeo 06 tdci 140bhp
  • Location:

Posted 18 September 2010 - 09:13 PM

130 bhp tddci mondeo estate 03 plate.
When ever I tow a caravan I have the problem that when going up long inclines on the motorway or when accelerating hard and long the car will jurk and the coil light will come on. Sometimes going into limp mode. The usual thing pull over turn the engine off and back on its ok.
Another thing which may be linked. That when coasting (foot off the accelerator) and then touch the accelerator at around 40mph the car jerks.
MPG when towing is 32 and when not towing around the 50 MPG mark.
Please help worried about going to a garage and end up spending 500 and still have the fault as mentioned on numerous threads.

Any ideas would be appreciated

Cheers :)

I know this thread was started some time ago but I would dearly like to know if you managed to get to the bottom of this problem as I have just returned home from my caravan holiday with exactly the same problem when towing. I have since changed the fuel filter and cleaned out the egr valve but as I will not know if this will be sorted until I go out towing again. As I say I would be pleased if you can give me any answers. Thanks Brian


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users