• Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Get Your Club gear
      Get Your Club gear

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
Zetec Dave

Focus Zetec niggles...........

10 posts in this topic

Hi everyone. I've just joined the forum as I've recently bought a rather nice black Focus 1.6 Zetec 2005 (new shape) and have a few issues with it which I hope someone can help me with.

I got it for a very good price from a Mazda main dealers and they threw in a 12 month Mazda warranty which just about covers everything. Just as well as I've noticed that the fuel gauge and 'distance left' display are very erratic. I presume this is a fuel level sender unit problem? It has been back once when they tried to replicate the problem. Obviously it didn't show up while they had the car but they they do accept from me that there is a problem and they are going have a 'proper' look next week.

Another less serious, but rather annoying thing is a horrible creaking from the passenger door panel. Can anyone please advise about this and any information about removing the door trim/panel would be appreciated too.

Finally the reception on AM is very poor with lots of crackling. I have found that the screw connection between the aerial and the roof mounting point is pretty corroded. Is this likely to be the problem?

Thanks in advance

David

Share this post


Link to post
Share on other sites
 

it most likley is the sender unit as ford have had problems with this, it could also be an earth fault check the earth on the battery post, but especially where it goes down to the body near the washer bottle as it is often soaked when the bottle is filled up. Remove and clean the terminal on the inner wing area, this means wire brush and WD40! Also the small earth wire on the back of the cylinder head needs to be checked.

creaking door cards are also a common problem i know people who have cured this by removing the card and putting some draugh excluder strip behind the card.

the reception proplem will most likely be the rusty connection at the ariel,hope this is of assistance

Share this post


Link to post
Share on other sites
it most likley is the sender unit as ford have had problems with this, it could also be an earth fault check the earth on the battery post, but especially where it goes down to the body near the washer bottle as it is often soaked when the bottle is filled up. Remove and clean the terminal on the inner wing area, this means wire brush and WD40! Also the small earth wire on the back of the cylinder head needs to be checked.

creaking door cards are also a common problem i know people who have cured this by removing the card and putting some draugh excluder strip behind the card.

the reception proplem will most likely be the rusty connection at the ariel,hope this is of assistance

Thank you for your reply. Can you advise how to remove the card/dor panel as there seem to be no screws or fixings visible.

Share this post


Link to post
Share on other sites

the screws will be covered by small plastic plugs once all removed the card should pull away from the door with plastic fixing clips attatched

Share this post


Link to post
Share on other sites
the screws will be covered by small plastic plugs once all removed the card should pull away from the door with plastic fixing clips attatched

I've just had a very good look at the door panel and there are'nt any screws or plastic plugs visible. i suspect everything is clipped in place. Unfortunately with clips, once unclipped they either break or lose their efficiency. Any more thoughts?

Share this post


Link to post
Share on other sites

sorry seniour moment

Share this post


Link to post
Share on other sites

Are you sure there are no screws?

But you are right about the clips, once off they normally break! But unfortunately it wont to get the panel off you have not got much choice.

Share this post


Link to post
Share on other sites
Are you sure there are no screws?

But you are right about the clips, once off they normally break! But unfortunately it wont to get the panel off you have not got much choice.

I've had a very good close look around the door and can't see any. No plugs either where there may be screws underneath. Mine is the latest model/shape of Focus 2005. I had a Mk1 and knew how to get the panel off that as I had to replace the central locking mechanism.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0