Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


andyanders

Running Sluggish

4 posts in this topic

I have just had a new flywheel and clutch fitted to my focus 1.8tdi(2003) and now it seems to be running very slowly.It seems as there is a lot less power than before these parts were fitted.please can someone shed any light on this problem.

Share this post


Link to post
Share on other sites
 

It could be that whilst the clutch/flywheel kit was being refitted a turbo or intercooler hose has not been attached correctly or has been damaged. Have a visual look around or take it back to where the stuff was fitted and let them have a detailed look.

Share this post


Link to post
Share on other sites

same thing happen on my sons car tured out to be the

intercooler hose had not been attached correctly :)

Share this post


Link to post
Share on other sites

thanks folks for the advice car now running fine after fixing pipe

to turbo.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now