Jump to content


Photo

No hot air coming from heater


  • Please log in to reply
5 replies to this topic

#1 mondy man

mondy man

    Member

  • New Member
  • PipPip
  • 28 posts
  • Ford Model: mondeo turbo diesel
  • Location:

Posted 16 September 2008 - 12:24 AM

Hi guys meant to add this one on to the previous question about the lack of power.
I am not getting any hot air out of the heater, there is the right amount of water in the header tank, the blower works correctly at all speeds, it just doesn't get hot, and the hot/cold selector nob does not turn all the way to cold or right round to hot, any ideas?
Cheers
Dave

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,465 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 16 September 2008 - 08:53 AM

could be the switch panel playing up try some wd40 on it

#3 mondy man

mondy man

    Member

  • New Member
  • PipPip
  • 28 posts
  • Ford Model: mondeo turbo diesel
  • Location:

Posted 16 September 2008 - 10:07 PM

could be the switch panel playing up try some wd40 on it

Thanks again

#4 Rikos

Rikos

    Too much time on the boards

  • New Member
  • PipPipPipPip
  • 857 posts
  • Ford Model: Fiesta 1.4 LX

Posted 17 September 2008 - 08:59 AM

Cant beat a bit of wd40 :lol:

Any joy mate?

#5 mondy man

mondy man

    Member

  • New Member
  • PipPip
  • 28 posts
  • Ford Model: mondeo turbo diesel
  • Location:

Posted 19 September 2008 - 10:10 PM

Cant beat a bit of wd40 :lol:

Any joy mate?


No, I had the heater panel off and there is a wierd cog that turns at an angle to the cable end and the wire that pushes through the bulk head was bent, so I bent it straight and it made no difference. I take it the heater matrix is under the windscreen scuttle and will have to be stripped to gain access to the other end of the wire, to see why the heater isnt going hot.
Dave

#6 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,465 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 19 September 2008 - 10:23 PM

could be a seized heater controlle valve common on a lot of fords

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users