Jump to content


Show
Photo

Speedo Not Worrking


  • Please log in to reply
6 replies to this topic

#1 sssnakeuk2001

sssnakeuk2001

    Settling In Well

  • Budding Enthusiast
  • PipPipPip
  • 34 posts
  • Ford Model: fusion 2 1.6 16v

Posted 04 September 2010 - 10:07 AM

Hi, i am hoping someone can help. My speedo has stopped working and the milage is no longer visible. Where the milage used to be now looks like -----------. I was thinking maybe a fuse so i looked for the fuse box, which i could not find. So i would not mind someone telling me where that is also. I should say i bought the car from the market and i never got any books etc.

Please can someone assist me.

Thanks in advance

Steph

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 MrrNoName

MrrNoName

    MrrNoName

  • New Member
  • PipPipPipPip
  • 200 posts
  • Ford Model: Focus Titanium
  • Location:

Posted 05 September 2010 - 04:09 PM

Hi, i am hoping someone can help. My speedo has stopped working and the milage is no longer visible. Where the milage used to be now looks like -----------. I was thinking maybe a fuse so i looked for the fuse box, which i could not find. So i would not mind someone telling me where that is also. I should say i bought the car from the market and i never got any books etc.

Please can someone assist me.

Thanks in advance

Steph


could be a fault with the dial cluster? or loose connection in the wireing behind? duno where the fuse box is as i dnt own a fusion sorry :P

#3 Claxxon

Claxxon

    Settling In Well

  • New Member
  • PipPipPip
  • 37 posts
  • Ford Model: Fusion 1.4TDi Zetec
  • Location: Scotland

Posted 06 September 2010 - 05:19 PM

could be a fault with the dial cluster? or loose connection in the wireing behind? duno where the fuse box is as i dnt own a fusion sorry :P


If you open the glove box fully and then disengage the clips that stop it coming any further forward you will see the fuse box. You might also find some stuff that has slipped down the back of the glove box :-)

#4 sssnakeuk2001

sssnakeuk2001

    Settling In Well

  • Budding Enthusiast
  • PipPipPip
  • 34 posts
  • Ford Model: fusion 2 1.6 16v

Posted 11 October 2012 - 06:02 PM

Hi what is the dial cluster and where can I find it. Is it easy to replace.

#5 Stoney871

Stoney871

    Resident Peacekeeper

  • Super Mod
  • 14,686 posts
  • Name: Clive
  • Ford Model: Focus mk2 1.8 TDCI Sport
  • Year: 2007
  • Location: Devon
Contributor

Posted 11 October 2012 - 06:10 PM

It's the dash piece where all your dials are.
A good search online should give you tips on removing it.
Another thing you can check is your battery.
How old is it and is it fully charged?
Low battery power can cause speedo cluster errors.

#6 sssnakeuk2001

sssnakeuk2001

    Settling In Well

  • Budding Enthusiast
  • PipPipPip
  • 34 posts
  • Ford Model: fusion 2 1.6 16v

Posted 13 October 2012 - 02:28 PM

Its so weird, My wife stalled the car today and low and behold the speedon came to life again so I think I have a loose connection somewhere. I wont look for it til it stops again, Ta for all help

#7 Giffer2

Giffer2

    Member

  • New Member
  • PipPip
  • 28 posts
  • Ford Model: Focus Econetic
  • Location: Bridgend

Posted 08 December 2012 - 10:21 PM

It's the speed sensor that's on it's way out. It's located in the top of the gearbox for non-abs Fusions but is part of the abs setup for abs based Fusions.
We had the sensor replaced in ours a couple of months ago, cost just over £100.

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users