Jump to content


Show
Photo

Rear Seat Entertainment System


  • Please log in to reply
2 replies to this topic

#1 ajlecky

ajlecky

    Newbie

  • Budding Enthusiast
  • Pip
  • 3 posts
  • Ford Model: S-Max

Posted 07 September 2010 - 09:46 AM

I have a fantastic 59 reg S-Max with the rear seat entertainment system. The reason we opted for the DVD player was to entertain our two young children on long drives. It has been working OK since we bought it in February but typicallly we set off for France and for some reason the DVD player has decided to not cooperate! We play a disc and within approx 30 mins (variable) the picture stops and we then get the Ford logo and nothing else. We thought it was something the children were doing but have checked and it's not them. We thought the disc was faulty but it happens on all the discs. We have tried cleaning the discs and the player itself but to no avail!

Any ideas how we can fix this problem so that our return from France (in two days time!) is more peaceful?

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 noddy

noddy

    Member

  • New Member
  • PipPip
  • 22 posts
  • Ford Model: S-max Titanium 2.5T X pack, Nav & DVD
  • Location: Wiltshire

Posted 11 September 2010 - 07:12 AM

Ours went through a phase of doing this but then cured itself after about a month or so. Not sure what the cause was although the screens seemed to be getting hotter than usual. Having said that I would be surprised if there is a thermal cutout fitted, so probably a red herring.

#3 ajlecky

ajlecky

    Newbie

  • Budding Enthusiast
  • Pip
  • 3 posts
  • Ford Model: S-Max

Posted 11 September 2010 - 05:09 PM

Ours went through a phase of doing this but then cured itself after about a month or so. Not sure what the cause was although the screens seemed to be getting hotter than usual. Having said that I would be surprised if there is a thermal cutout fitted, so probably a red herring.



Thank you for your reply. We have booked it into Fords for them to have a look. I bet it works fine when it's there!


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users