• Get Your Club gear
      Get Your Club gear
    • Join Premium & Save
      Join Premium & Save
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Share Your Car Experience
      Share Your Car Experience
    • Huge Range of Ford Parts
      Huge Range of Ford Parts

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.

Sign in to follow this  
Followers 0

St200 Lumpy Drive

2 posts in this topic

Hello all i recently got an st200 mondeo and its recently started playing around, acceleration is fine and motorway driving is also fine but if your driving around town and holding a steady anything under 50 it seems to judder and keeps trying to hold back. Its got 8mm magnecore leads which are around 15k old and irodium plugs which are also around 15k old so i would of thought they would have both been ok. Every now and then the idle will change (not drastic) sometimes it will idle at around 1000 and others around 650 so im wondering if there linked. Im going to have the throtle body off and the idle valve off to give them a good clean up to see if theres any difference but has anyone else got any other sugestions? Thank you

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0