Jump to content


Photo

Help Car Just Died


  • Please log in to reply
3 replies to this topic

#1 ryan79

ryan79

    Newbie

  • New Member
  • Pip
  • 9 posts
  • Ford Model: 1.25 zetec

Posted 29 September 2010 - 09:15 AM

HI can anybody sergest what could be wrong with mt escort. I went out this morrning and drove it 7miles and the car just wont start. First the radio stoped working, and then the car started the jurk in first and second and the completly died had to get the car towed home by my friend. I am no car buff but mt dash lights are very dim which in my mind is the batt had it can any think what it could be thanks.

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 vinnyvangough

vinnyvangough

    Ford Enthusiast

  • Moderator
  • 2,325 posts
  • Name: Steve
  • Ford Model: 2003 Focus TDCi, Escort Mk6 RS2000, Mk2
  • Year: 2003
  • Location: Devon

Posted 29 September 2010 - 12:40 PM

Sounds like its either battery or alternator has given up.

#3 ryan79

ryan79

    Newbie

  • New Member
  • Pip
  • 9 posts
  • Ford Model: 1.25 zetec

Posted 29 September 2010 - 01:44 PM

Sounds like its either battery or alternator has given up.

just got a new batt and i am wating for recovery to cheak that everything else is ok thanks for the responce just hope its the batt and not anything else alternator was 8v out put

#4 ryan79

ryan79

    Newbie

  • New Member
  • Pip
  • 9 posts
  • Ford Model: 1.25 zetec

Posted 30 September 2010 - 12:03 PM

just got a new batt and i am wating for recovery to cheak that everything else is ok thanks for the responce just hope its the batt and not anything else it was both the aultator is out out a 8v charge




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users