Jump to content


Show
Photo

Clutch Problem Mondeo Mk3


  • Please log in to reply
1 reply to this topic

#1 benscab

benscab

    Member

  • New Member
  • PipPip
  • 13 posts
  • Ford Model: MONDEO MK3 2002 HATCHBACK ZETEC PETROL

Posted 01 October 2010 - 04:35 PM

JUST BOUGHT A 02 MONDEO ZETEC AT AUCTION, DRIVING IT FOR THE FIRST TIME I NOTICED IT WAS VERY DIFFICULT TO SET OFF IN FIRST GEAR AS THOUGH SOMETHING WAS HOLDING THE CAR BACK. THE ABS LIGHT IS ON ALSO ( DONT KNOW IF THAT COULD BE ANYTHING TO DO WITH IT ). ON ACCELERATION ESPECIALLY UPHILL THE CLUTCH SLIPS QUITE BADLY. IS IT JUST A CASE OF REPLACING THE 2 PART CLUTCH, OR IS THERE MORE TO IT, IVE HEARD TALES OF THE DREADED DUAL MASS FLYWHEEL BUT DONT KNOW ANYTHING ABOUT IT. IF IT MEANS ANYTHING TOO, THE CLUTCH PEDAL IS BITING RIGHT AT THE VERY TOP. ANY HELP IN REDUCING REPAIR COST WOULD BE GREATLY APPRECIATED AND THANKYOU IN ANTICIPATION OF YOUR HELP. BEN.

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 flying clutchman

flying clutchman

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 155 posts
  • Ford Model: transit2.5D
  • Location:

Posted 04 October 2010 - 11:07 AM

The dual-mass flywheel is not normally a problem on the petrol models. Two-part clutch will normally solve the problem. Obviously check the concentric for leaks and bearing failure but most times you can avoid changing these although they're not too dear (about 50 from euro car parts)


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users