Jump to content


Photo

Knocking Noise From Engine


  • Please log in to reply
4 replies to this topic

#1 gelliott

gelliott

    Member

  • New Member
  • PipPip
  • 12 posts
  • Ford Model: 07 mondeo tdci

Posted 05 October 2010 - 10:38 AM

hi there got 07 mondy estate tdci and every now and then it has a really heavy knock from engine and some times the battery light flashes on took it to the garage were i got it as it was under warranty and they changed the injectors but it is still doing it and the warranty is out now and they say it sounds normsl but i heard outhers and mine is louder it has 106000 motorway miles on can anyone help as it seems to be im bangin my head of a wall tryin to find out the problem i just want to fix it
thanx gary

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 fishpond 47

fishpond 47

    Feet Under The Table

  • FOC Supporters
  • 363 posts
  • Ford Model: mk3 mondeo x2 + a ka

Posted 05 October 2010 - 07:22 PM

Note: If the noise was/is still there after they changed the injectors(so called fixed the problem) via the warrenty then your warrenty still stands as the problem hasnt been fix whilst the problem was first reported whilst the warrenty was still valid, take it back and tell them to sort it and mention trading standards, DONT be fobbed off, go to another ford dealer and get there opinion as to the noise

#3 Simon L

Simon L

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Ford Model: Mondeo TDCi 115 Zetec

Posted 08 October 2010 - 09:46 AM

hi there got 07 mondy estate tdci and every now and then it has a really heavy knock from engine and some times the battery light flashes on took it to the garage were i got it as it was under warranty and they changed the injectors but it is still doing it and the warranty is out now and they say it sounds normsl but i heard outhers and mine is louder it has 106000 motorway miles on can anyone help as it seems to be im bangin my head of a wall tryin to find out the problem i just want to fix it
thanx gary


I had the exact same symptoms with mine, not guaranteed to be the same thing but worth a shot. My local garage changed the pulley on the alternator system and replaced the belt. Good as gold ever since, the knock has gone, as has the occasional squeek and the battery light problem has not returned (been a year now since this work was completed). I would agree with the warranty comment above in that the problem has not been resolved so the original call still stands.

Good luck, hope you get it sorted.

#4 avspidr

avspidr

    Member

  • New Member
  • PipPip
  • 10 posts
  • Ford Model: Mondeo Ghia Tdci Estate

Posted 23 October 2010 - 07:51 AM

Do you still have the same problem? Does having the A/C on or off make any difference? as I believe they are run off the same belt & tensioner?

#5 gelliott

gelliott

    Member

  • New Member
  • PipPip
  • 12 posts
  • Ford Model: 07 mondeo tdci

Posted 02 November 2010 - 05:28 PM

yer the problem is still there it gets worse wen i put on heated windscreen


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users