Jump to content


Photo

Please Help


  • Please log in to reply
4 replies to this topic

#1 maxalex

maxalex

    Newbie

  • New Member
  • Pip
  • 5 posts
  • Ford Model: 07 focus 1.6 zetec

Posted 09 October 2010 - 04:27 PM

Hello,can anyone please help me ?
I have a ford focus 1.6 zetec on a 07 plate,
I was on my way to Wales today when as i was approaching the M6 my outside temp reading disappeared followed by the handbrake warning light coming up then the seatbelt light came on then the airbag light made an appearance then the indicators stopped working.I called the AA and they checked the alternater which was fine and checked all the earths they were also ok and they looked at all the connections in the car which were all good,they towed me to Toddington to switch drivers,after coming back from having a cuppa the AA man said everything is working but still towed me back to be on the safe side,i'm now worried about driving it.
I would be very grateful for any advice,
thanks,Alex. :)

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 artscot79

artscot79

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 7,995 posts
  • Name: arthur
  • Ford Model: focus mk2 ti-vct
  • Year: 2006
  • Location: Fife

Posted 09 October 2010 - 08:38 PM

Hello,can anyone please help me ?
I have a ford focus 1.6 zetec on a 07 plate,
I was on my way to Wales today when as i was approaching the M6 my outside temp reading disappeared followed by the handbrake warning light coming up then the seatbelt light came on then the airbag light made an appearance then the indicators stopped working.I called the AA and they checked the alternater which was fine and checked all the earths they were also ok and they looked at all the connections in the car which were all good,they towed me to Toddington to switch drivers,after coming back from having a cuppa the AA man said everything is working but still towed me back to be on the safe side,i'm now worried about driving it.
I would be very grateful for any advice,
thanks,Alex. :)


rather strange i will say it again check the battery isnt a lead acid battery first of all has to be silver/lead calcium this can cause all sorts of weird gremlinsd and is overlooked by even the aa simply a lead acid just boils after that ide get it checked at ford my bets the battery

#3 maxalex

maxalex

    Newbie

  • New Member
  • Pip
  • 5 posts
  • Ford Model: 07 focus 1.6 zetec

Posted 10 October 2010 - 08:12 AM

rather strange i will say it again check the battery isnt a lead acid battery first of all has to be silver/lead calcium this can cause all sorts of weird gremlinsd and is overlooked by even the aa simply a lead acid just boils after that ide get it checked at ford my bets the battery

Thanks i will check this out this morning and let you know how i get on,thanks for taking the time to help out.

#4 maxalex

maxalex

    Newbie

  • New Member
  • Pip
  • 5 posts
  • Ford Model: 07 focus 1.6 zetec

Posted 12 October 2010 - 08:09 PM

I checked the battery and its the right one so unfortunatly no joy, is there any other ideas why this could have happend i would be grateful for any more tips,
thanks,Alex.

#5 artscot79

artscot79

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 7,995 posts
  • Name: arthur
  • Ford Model: focus mk2 ti-vct
  • Year: 2006
  • Location: Fife

Posted 12 October 2010 - 08:29 PM

I checked the battery and its the right one so unfortunatly no joy, is there any other ideas why this could have happend i would be grateful for any more tips,
thanks,Alex.


im at a loss to be honest i suggest taking it to ford to have it checked out these lights all at once may indicate something that they know of but we dont


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users