Jump to content


Photo

Escort 1.6 Brake / Hand-Brake Issue


  • Please log in to reply
2 replies to this topic

#1 terry2010

terry2010

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Ford Model: Escort

Posted 12 October 2010 - 10:58 PM

Hello i drive a Escort 1.6 zetec. Basically my hand-brake goes up quite a few clicks and doesn't seem to hold very well on steep hills, has to be applied very high. I have checked my rear drums and pads. My drums are worn but not to the point where they need replacing but i did fit new pads.
I also checked the hand-brake cable which i cannot adjust any further as it is already on the tightest setting. It sounds to me that the hand-brake cable is stretched.. so dont want to fork out for drums if they dont need changing.. but would appreciate any advice. Thank-you
:)

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 lublin

lublin

    Settling In Well

  • New Member
  • PipPipPip
  • 98 posts
  • Ford Model: Escort Estate 1.6 16v . Built 14/11/95.

Posted 13 October 2010 - 08:20 AM

Hello i drive a Escort 1.6 zetec. Basically my hand-brake goes up quite a few clicks and doesn't seem to hold very well on steep hills, has to be applied very high. I have checked my rear drums and pads. My drums are worn but not to the point where they need replacing but i did fit new pads.
I also checked the hand-brake cable which i cannot adjust any further as it is already on the tightest setting. It sounds to me that the hand-brake cable is stretched.. so dont want to fork out for drums if they dont need changing.. but would appreciate any advice. Thank-you
:)

Try pressing really hard on the brake pedal, with the engine running, and pumping the handbrake up and down. This worked on my Escort when I first bought it. Also, the auto adjusters could be stuck.

#3 terry2010

terry2010

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Ford Model: Escort

Posted 20 October 2010 - 11:14 AM

Thanks mate but that didn't make any difference. Will be replacing the hand-brake in the next week or so, will let you know if that solves it.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users