Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
Cortexx

57 Plate Ford Ka Speedo Light

7 posts in this topic

Hey Guys,

Basically my sisters 57 Plate KA Speedo light keeps randomly turning itself off at night whilst driving, and its getting to the stage where she cant see her speed on dark, unlit roads.

Its just a simple bulb infront of the speedo that lights up the entire panel from the front.

Now i dont think the bulb is the issue, it sounds like a loose connection somewhere, but ive heard you need to take out the whole dash to get to it, is this true?

Could anyone help out on this issue? i would like to fix it myself but if thats not possible then maybe someone here lives around my area? Southend On Sea, Essex.

Cheers!

Share this post


Link to post
Share on other sites
 

without taking a look at the ka that I'm 'doing up' and in most cars you dont normally have to remove the whole dash to get the 'clocks/dials' out, have a good look around that area and you will probably find some hidden screws, I'll have a look tomorrow on this one of mine and get back to you

Share this post


Link to post
Share on other sites

Hey fishpond, I had a quick look and yes, it does look like the whole dash needs to come out, nightmare!

Share this post


Link to post
Share on other sites

Hey Guys,

Basically my sisters 57 Plate KA Speedo light keeps randomly turning itself off at night whilst driving, and its getting to the stage where she cant see her speed on dark, unlit roads.

Its just a simple bulb infront of the speedo that lights up the entire panel from the front.

Now i dont think the bulb is the issue, it sounds like a loose connection somewhere, but ive heard you need to take out the whole dash to get to it, is this true?

Could anyone help out on this issue? i would like to fix it myself but if thats not possible then maybe someone here lives around my area? Southend On Sea, Essex.

Cheers!

Hi mate, like u said its more then likely to be the connection.. have u checked fuses and all the other basics? i cant remember with them dashboards weather u can pop them out easily from the back... but if ur like me and have slim fingers u can get ur hand behind the dash but you have to really place ya self in a akward position... head in the footwell and legs hanging out the window lol.. if ya fingers fit u can wiggle the connections that way... u should have access to the back of the dashboard through the footwell.. but its all feel no see, so u will be there for a while... if that fails .. resort back to the old traditional 'tap the dashboard generously' it does sometimes work... if all fails.. being a 57 plate (new and all cramed in so u cant get to !Removed!) its gunna have to be a garage job, but they shouldnt charge that much to be fair!! good luck

Share this post


Link to post
Share on other sites

well had a quick look tonight and the clock surround has got two screws at the top so I would imagine that the clocks would be accessible via another two or four screws then just slide forward (not wanting to my ka to bits tonight as it goes for mot tomorrow)

Share this post


Link to post
Share on other sites

Thanks for the info guys, i had a look at it today and almost sliced my fingers open lol.

I think i will be taking it to a garage, or ask a ford mechanic is they fancy doing a private job,

Thanks for all the info though, been a great help!

Share this post


Link to post
Share on other sites

Hey Guys,

Basically my sisters 57 Plate KA Speedo light keeps randomly turning itself off at night whilst driving, and its getting to the stage where she cant see her speed on dark, unlit roads.

Its just a simple bulb infront of the speedo that lights up the entire panel from the front.

Now i dont think the bulb is the issue, it sounds like a loose connection somewhere, but ive heard you need to take out the whole dash to get to it, is this true?

Could anyone help out on this issue? i would like to fix it myself but if thats not possible then maybe someone here lives around my area? Southend On Sea, Essex.

Cheers!

Mine did the same a couple of weeks ago.

A little bit un-nerving as you feel like you have no lights on :P

The whole dash has to come out.

There are screws behind the radio and under the clock, from what I remember.

The actual 'light' is on the top of the speedo cluster.

My bulb hadn't gone the connection is made using a paper strip with copper strips on.

Re seated the bulb and it has been on since.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0