Jump to content


Show
Photo

57 Plate Ford Ka Speedo Light


  • Please log in to reply
6 replies to this topic

#1 Cortexx

Cortexx

    Settling In Well

  • New Member
  • PipPipPip
  • 68 posts
  • Ford Model: Fiesta

Posted 13 October 2010 - 01:38 PM

Hey Guys,

Basically my sisters 57 Plate KA Speedo light keeps randomly turning itself off at night whilst driving, and its getting to the stage where she cant see her speed on dark, unlit roads.

Its just a simple bulb infront of the speedo that lights up the entire panel from the front.

Now i dont think the bulb is the issue, it sounds like a loose connection somewhere, but ive heard you need to take out the whole dash to get to it, is this true?

Could anyone help out on this issue? i would like to fix it myself but if thats not possible then maybe someone here lives around my area? Southend On Sea, Essex.

Cheers!

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 fishpond 47

fishpond 47

    Feet Under The Table

  • FOC Supporters
  • 363 posts
  • Ford Model: mk3 mondeo x2 + a ka

Posted 13 October 2010 - 05:45 PM

without taking a look at the ka that I'm 'doing up' and in most cars you dont normally have to remove the whole dash to get the 'clocks/dials' out, have a good look around that area and you will probably find some hidden screws, I'll have a look tomorrow on this one of mine and get back to you

#3 Cortexx

Cortexx

    Settling In Well

  • New Member
  • PipPipPip
  • 68 posts
  • Ford Model: Fiesta

Posted 14 October 2010 - 07:35 PM

Hey fishpond, I had a quick look and yes, it does look like the whole dash needs to come out, nightmare!

#4 portelli4

portelli4

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: focus lx tdci

Posted 14 October 2010 - 07:51 PM

Hey Guys,

Basically my sisters 57 Plate KA Speedo light keeps randomly turning itself off at night whilst driving, and its getting to the stage where she cant see her speed on dark, unlit roads.

Its just a simple bulb infront of the speedo that lights up the entire panel from the front.

Now i dont think the bulb is the issue, it sounds like a loose connection somewhere, but ive heard you need to take out the whole dash to get to it, is this true?

Could anyone help out on this issue? i would like to fix it myself but if thats not possible then maybe someone here lives around my area? Southend On Sea, Essex.

Cheers!



Hi mate, like u said its more then likely to be the connection.. have u checked fuses and all the other basics? i cant remember with them dashboards weather u can pop them out easily from the back... but if ur like me and have slim fingers u can get ur hand behind the dash but you have to really place ya self in a akward position... head in the footwell and legs hanging out the window lol.. if ya fingers fit u can wiggle the connections that way... u should have access to the back of the dashboard through the footwell.. but its all feel no see, so u will be there for a while... if that fails .. resort back to the old traditional 'tap the dashboard generously' it does sometimes work... if all fails.. being a 57 plate (new and all cramed in so u cant get to !Removed!) its gunna have to be a garage job, but they shouldnt charge that much to be fair!! good luck

#5 fishpond 47

fishpond 47

    Feet Under The Table

  • FOC Supporters
  • 363 posts
  • Ford Model: mk3 mondeo x2 + a ka

Posted 15 October 2010 - 06:19 PM

well had a quick look tonight and the clock surround has got two screws at the top so I would imagine that the clocks would be accessible via another two or four screws then just slide forward (not wanting to my ka to bits tonight as it goes for mot tomorrow)

#6 Cortexx

Cortexx

    Settling In Well

  • New Member
  • PipPipPip
  • 68 posts
  • Ford Model: Fiesta

Posted 16 October 2010 - 07:12 PM

Thanks for the info guys, i had a look at it today and almost sliced my fingers open lol.

I think i will be taking it to a garage, or ask a ford mechanic is they fancy doing a private job,

Thanks for all the info though, been a great help!

#7 aspe

aspe

    Newbie

  • New Member
  • Pip
  • 9 posts
  • Ford Model: Focus & Ka

Posted 24 November 2010 - 08:22 PM

Hey Guys,

Basically my sisters 57 Plate KA Speedo light keeps randomly turning itself off at night whilst driving, and its getting to the stage where she cant see her speed on dark, unlit roads.

Its just a simple bulb infront of the speedo that lights up the entire panel from the front.

Now i dont think the bulb is the issue, it sounds like a loose connection somewhere, but ive heard you need to take out the whole dash to get to it, is this true?

Could anyone help out on this issue? i would like to fix it myself but if thats not possible then maybe someone here lives around my area? Southend On Sea, Essex.

Cheers!


Mine did the same a couple of weeks ago.
A little bit un-nerving as you feel like you have no lights on :P
The whole dash has to come out.
There are screws behind the radio and under the clock, from what I remember.
The actual 'light' is on the top of the speedo cluster.
My bulb hadn't gone the connection is made using a paper strip with copper strips on.
Re seated the bulb and it has been on since.

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users