• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save


gfj

Multi Function Display Indicator Stays Lit On 2009 Fiesta

7 posts in this topic

Can anyone help? I have a problem on the Multi Function Display on my 2009 Fiesta Style.

On the left hand side of the display there are 4 indicators. All indicators come on when the ignition is turned on,

they should then go out [if the radio/cd is off]. On my car the bottom indicator stays on -- it is shaped like a cog with a circle in the middle. I have been told this is a "settings" indicator, but I can't find any info.

This display has radio, clock, date info etc. Everything seems to be working ok so Im not sure where to look.

Share this post


Link to post
Share on other sites
 

Same on mine, that cog is always lit. Never had any issues with it,

Share this post


Link to post
Share on other sites

I think the cog stays lit, because it corresponds to the "menu" button, which is still active, even with the radio off.

Share this post


Link to post
Share on other sites

I think the cog stays lit, because it corresponds to the "menu" button, which is still active, even with the radio off.

Yep, and green means "available" and red means "active". So when the stereo is off, the menu button is lit up and the settings "cog", and then you turn the stereo on and everything else lights up. Simples

Share this post


Link to post
Share on other sites

Thanks for the info.

I had a look at another 09 Fiesta. The indicator went off when the radio was switched off [ignition still on].

I even asked at a Ford Main Dealer -- they did'nt seem to have much idea. They just repeated that it was something to do with settings.

I will let you know if I get to the bottom of it.

Share this post


Link to post
Share on other sites

Hi, I know this is an old thread but I also have the settings indicator stagings on (green) when the radio is off.

I have a 2012 fiesta zetec s

Any ideas?

Thanks, Gary

Share this post


Link to post
Share on other sites

same here with the green cog on radio display..ive been trying for hours to find out about this..think I will go back to the dealers..will let you know if I find out anything...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now