Jump to content


Photo

Heated Windscreen Not Heating?


  • Please log in to reply
2 replies to this topic

#1 stevenmccarthy

stevenmccarthy

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Mondeo 2.0d Titanium 08

Posted 20 October 2010 - 05:07 PM

Please help! I have a ford Mondeo 08 and my heated windscreen is not heating any ideas? The light comes on the dash? There are not breaks in the filaments? The screen is connected? Could it be my pollen filter? I have been told this could be stopping my windscreen from heating up? If this could be the case how do i change it? Unfortunately my car is out of warranty as it was a damage repairable not that you would know!

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 ilanbutler

ilanbutler

    Member

  • New Member
  • PipPip
  • 26 posts
  • Name: ilan
  • Ford Model: Focus ST170
  • Year: 2002
  • Location: Shropshire

Posted 20 October 2010 - 06:31 PM

on my heated window it was a broken ribbon cable that connects the window to an earth point on the car, but your car is pretty new so its more likely to be a fuse or relay there is a guide here on the relays and fuses for your car
http://www.fordwiki.co.uk/index.php/Fuse_%26_Relay_Information_-_Mk4

there pretty easy to replace
hop this helps
ilanbutler

#3 stevenmccarthy

stevenmccarthy

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Mondeo 2.0d Titanium 08

Posted 20 October 2010 - 07:27 PM

Thanks for your input i will have a look tomorrow.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users