Jump to content


Photo

Electric Windows Not Working


  • Please log in to reply
5 replies to this topic

#1 fsmith

fsmith

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Ford Model: focus

Posted 21 October 2010 - 01:07 AM

hi im new to this forum but i think this is the right place to post this i have a problem with my windows. They work on and off. The car as always done it since i had it but its starting to bother me alot now.

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 ilanbutler

ilanbutler

    Member

  • New Member
  • PipPip
  • 26 posts
  • Name: ilan
  • Ford Model: Focus ST170
  • Year: 2002
  • Location: Shropshire

Posted 21 October 2010 - 01:20 AM

Hi i have had a similar problem mine was down to a controller unit behind the fuse box located at the back of the glove box. But the quickest way to get to it is to remove the carpet underneath the glovebox and stick your hand up there. It sticks out from it and is clipped in on mine it was lose though so i just pushed it in otherwise get a new one or second hand from the scrapper. Failing this its probably the relay/fuse or window motor but its unlikley to be the motor if its more than one window.
Good Luck
ilanbutler

#3 fsmith

fsmith

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Ford Model: focus

Posted 21 October 2010 - 12:19 PM

thanks for a quick answer i will try it later on ..

#4 fsmith

fsmith

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Ford Model: focus

Posted 28 October 2010 - 12:38 PM

Hi i looked at what you said i found a black rectangular object on the back of the fuse box i took it out blew the dust from it and put it back in and hey presto it works perfectly, thanks ilanbutler

#5 gennibean

gennibean

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Name: Genevieve
  • Ford Model: Fiesta Mk 3
  • Year: 1994
  • Location: Northamptonshire

Posted 12 September 2014 - 01:30 AM

Hi, I'm new to with a 1994 Fiesta mk 3. Have tried what was said but my passenger side front electric window motor still won't work. Any ideas you guys? Thanks Gennibean.



#6 artscot79

artscot79

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 8,010 posts
  • Name: arthur
  • Ford Model: focus mk2 ti-vct
  • Year: 2006
  • Location: Fife

Posted 12 September 2014 - 03:16 AM

By the age of the car ide say the motor has likely gone the fiesta was prone to water getting into the motor the runners corroding and wires breaking also check the fuses

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users