• 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Share Your Car Experience
      Share Your Car Experience
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save


Sign in to follow this  
Followers 0
griff488

Knocking From The Engine Bay!!

4 posts in this topic

hello all!

I'm hoping someone can help me before i take the petrol and matches to my other halfs Focus!!

It is a 2000 W reg 1.8LX and has a knock from the front end under acceleration.

List of parts replaced so far:

Lower arms (both sides)

Anti roll bar drop links (both sides)

Track rod ends

O/S driveshaft

O/S wheel bearing

It is starting to get beyond a joke and my local garage who are pretty good can't find anything either!! Its been through 3 MOT's with this knocking and nothing has been found.

It gets worse the harder you accelerate and higher the speed to the point where its almost undriveable!!

The only thing i think it could be now is the engine mounts but i'm open to suggestions!?!?!?!

Does anyone know how many engine mounts there are?

Help!!!!!!!

Cheers Griff

Share this post


Link to post
Share on other sites
 

Engine mounts can knock if worn under acceleration.

Share this post


Link to post
Share on other sites

Engine mounts can knock if worn under acceleration.

try the radiator as dumb as it sounds it doesnt sit tight and can move back and forward in its clips which will create a knock short of that it will be the mounts usually the one under the airbox or the lower engine mount under the car are to blame

Share this post


Link to post
Share on other sites

hi, check that the side engine cover bolts in the front wheel arch are re-installed, sometimes the guys cant be bothered putting them back in, or forget, i had that on my car, two 9/16 bolts either side sortde it.

Still have rear bushes to do, that doesnt cause loud noise though, but i can see play.

Check that your wheel nuts are tight, and not worn to the point they are contacting drum/disk but not actually gripping steel wheels.

Nothing more annoying than a noise you cant trace mate.. good luck

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0