Jump to content


Photo

Cougar V6 Rear De-Mister & Intermitent Wiper


  • Please log in to reply
2 replies to this topic

#1 riksta32

riksta32

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: cougar

Posted 09 November 2010 - 04:03 PM

i have a ford cougar 2.5 v6, after leaving my lights on 1 day - battery was flat, i got the jump leads & got it going - after that the rear de-mister would'nt work (no light on button either), i've checked the fuse & its ok, also my wipers won't work on intermitent, both happened after jump starting the car, any ideas?

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,558 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 09 November 2010 - 04:30 PM

depending on the year of your cougar it could have a smart charge system on it and jump starting is not recomended as with the battery being completly dead up to 18 volts could be transmitted through the system when the car fires up,you need to check all fuses/relays,for signs of damage. if its not a smart charge system i would still say its a fuse/relay problem.

#3 riksta32

riksta32

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: cougar

Posted 21 November 2010 - 12:37 AM

will have 2 check these fuses over again - thanks


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users