Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
gypsyboy

Loss Of Power Turbo?

2 posts in this topic

hello everyone my other half has got a focus tdci 115BHP 2003.

i have had various problems but lets leave that for the moment.

the car has suddenly lost power and its like the turbo is not working???

the car idle's ok and it drives ok but there is no ummmph when the turbo should kick in.

i was always led to believe that if your turbo did not work on a diesel then it would run and idle like a bag of spanners.

any ideas please.

Share this post


Link to post
Share on other sites
 

hi sounds like you have same prob as myself. only thing that has been said on here so far is split intercooler pipe. please post what ever you find out thanks andy

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0