Jump to content


Show
Photo

Front Windscreen De-Icer On The Way Out?


  • Please log in to reply
2 replies to this topic

#1 noddy

noddy

    Member

  • New Member
  • PipPip
  • 22 posts
  • Ford Model: S-max Titanium 2.5T X pack, Nav & DVD
  • Location: Wiltshire

Posted 30 November 2010 - 07:27 AM

Wondered if anyone had a similar problem to my windscreen where the de-icer has just started to only do one side and in stripes.
Does this mean it will soon stop working altogether?
More importantly, does it mean a new windscreen as that sounds expensive?

I fear the worst.

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 Gazjs

Gazjs

    Area Rep: Central and North Scotland (Detailing Obsessive)

  • New Member
  • PipPipPipPipPip
  • 2,873 posts
  • Ford Model: Fiesta Mk 6 Facelift
  • Location:

Posted 30 November 2010 - 09:20 AM

If you are on about the heated screen. I believe that each side works on a different fuse. So give the fuses a check :)

#3 noddy

noddy

    Member

  • New Member
  • PipPip
  • 22 posts
  • Ford Model: S-max Titanium 2.5T X pack, Nav & DVD
  • Location: Wiltshire

Posted 22 December 2010 - 08:02 AM

Thanks Gazjs.
I should have thought of looking at the fuse.
You were right. I transposed the fuses over and the fault swapped sides. One fuse 5.36 though!!! A special, big fuse apparently!


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users