Jump to content


Show
Photo

USING WATER


  • Please log in to reply
2 replies to this topic

#1 SPUD45

SPUD45

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: MONDEO
  • Location:

Posted 05 October 2008 - 07:50 PM

hey lads hows things listen im just having a problem with my car a mate put me onto this site my mondeo is a 1.8 02 model and its using water now straght away you would think its head i thought so to had it checked for carbon in the water also water and oil not mixing its not over heating the lad i bought it off had put to thermostats into it the last one lasted two months i had just put one in it and temp sensor but its still using it the amount of water its using put it this way you would have to check it every two days other wise it drops below min level in the water bottle (for circulating the water around the engine). well i have had two lads lookin at it and they cant come up with the answer now there both certain that its not head but they have nt taken it off any help would be great maybe some of you ford specialists might give me a dig out :unsure:

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,463 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 06 October 2008 - 02:49 PM

i would have said it was the head gasket thats gone but if theres no evidence of white scum on the filler capit its hard to know. it Could be leaking through the water pump. This happens when the pump bearing gets worn. It drips, but engine heat can make it hard to spot as it dries the leaking drips quickly.

#3 SPUD45

SPUD45

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: MONDEO
  • Location:

Posted 06 October 2008 - 08:46 PM

[quote name='mintalkin' date='Oct 6 2008, 03:39 PM' post='5837']
i would have said it was the head gasket thats gone but if theres no evidence of white scum on the filler capit its hard to know. it Could be leaking through the water pump. This happens when the pump bearing gets worn. It drips, but engine heat can make it hard to spot as it dries the leaking drips quickly.
[you could be rite ill check it out and get back to you cheers bud


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users