Jump to content


Photo

Eac Failure


  • Please log in to reply
2 replies to this topic

#1 41scotty

41scotty

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Fiesta Finesse

Posted 18 December 2010 - 08:16 PM

I have had my ford fiesta finesse(53) for about 8 months.
Bought from Arnold Clark in April.
Yesterday I received an "EAC FAIL" on my dashboard and engine cut out.
I switched the engine off and turned it back on, everything seemed fine.
Its not happened again SO FAR and I'm worried about possible consequences.
Any ideas about what I should do?

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,467 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 19 December 2010 - 09:39 AM

this is a common problem which ford do not know how to cure fully,replacing the throttle body, sensor and wiring loom sometimes fixes the problem but not always,i would get back to arnold clark and play up as this is a manufactor problem, what warrenty did you get with the car? you could try ford customer services on 08458411111, also plenty of other people with the same problem
http://www.google.co...fiesta eac fail

#3 41scotty

41scotty

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Fiesta Finesse

Posted 19 December 2010 - 03:17 PM

right now im living in glasgow
and its heavy snowfall and ice everywhere
could it be that maybe the sensor has just frozen?

this is what ive been told from a mechanic
is it possible?


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users