Jump to content


Show
Photo

Washer Jet Fuse Location


  • Please log in to reply
1 reply to this topic

#1 r0b3r7

r0b3r7

    Settling In Well

  • New Member
  • PipPipPip
  • 76 posts
  • Ford Model: 2004 Focus Zetec

Posted 22 December 2010 - 09:36 AM

Tearing my hair out. I've looked on the net and in the owners manual but cannot find the exact location and number of the fuse that operates the washer jets? Stupid iPhone won't let me search, so apologies if this has been asked before

Cheers

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 H3lly

H3lly

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 282 posts
  • Name: k
  • Ford Model: Mk1 Focus
  • Year: 2003
  • Location: Dublin

Posted 22 December 2010 - 02:31 PM

I had the same problem with the washer not working. I taught maybe the water had frozen but there was no noise from the pump. I had been meaning to check the fuse but didn't. Anyway I was stuck in traffic for ages yesterday so the car was well warmed up. Then on my way home I flicked on the rear wiper and the wash came on too as well as the fronts. If your sure it's blown I have details of the fuses from haynes (02 - 04).

f53 - heated windscreen washer jets

f43 - el windows, rear screen wash system

f55 - windscreen wash / wipe system


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users