Jump to content


Photo
- - - - -

Quick Clear Windscreen


  • Please log in to reply
11 replies to this topic

#1 Rikos

Rikos

    Too much time on the boards

  • Budding Enthusiast
  • PipPipPipPip
  • 858 posts
  • Ford Model: Fiesta 1.4 LX

Posted 07 October 2008 - 09:00 AM

Hello all,

I used my quick clear windscreen yesterday morning and it didnt work fully.

It cleared most of the windscreen but left a patch in uncleared about 4 inches wide going from bottom to top. Is there anything than can be done or is it a case of a replacement windscreen.

Cheers,
Rik

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,480 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 07 October 2008 - 03:00 PM

if it only left a patch uncleared i think it would be some damaged elements someware

#3 Rikos

Rikos

    Too much time on the boards

  • Budding Enthusiast
  • PipPipPipPip
  • 858 posts
  • Ford Model: Fiesta 1.4 LX

Posted 08 October 2008 - 08:57 AM

Thats what i thought, which i think will mean a new windscreen. I have got a warranty and it does say it's covered but the ford garage near me wont do it unless i pay for it first so may have to go back to the original garage that i bought the car from.

#4 aztecbandit1

aztecbandit1

    Settling In Well

  • New Member
  • PipPipPip
  • 71 posts
  • Ford Model: Nissan Skyline R33 GT-T :-)
  • Location:

Posted 09 October 2008 - 12:32 PM

Ay up Rik, sounds like your have part of the foil strip either at the top or bottom of the screen broken so not making full contact hence the patches? where abouts does the screen stay fogged up?

#5 Rikos

Rikos

    Too much time on the boards

  • Budding Enthusiast
  • PipPipPipPip
  • 858 posts
  • Ford Model: Fiesta 1.4 LX

Posted 09 October 2008 - 12:35 PM

Right in front of the drivers side about 4 inches across and then there are a few odd lines over the windscreen

#6 aztecbandit1

aztecbandit1

    Settling In Well

  • New Member
  • PipPipPip
  • 71 posts
  • Ford Model: Nissan Skyline R33 GT-T :-)
  • Location:

Posted 09 October 2008 - 12:42 PM

Right in front of the drivers side about 4 inches across and then there are a few odd lines over the windscreen


Sometimes they have a bad contact point thats corroded and where the wires connect to the screen, if you can find which side the connector is to the screen check the wiring connector and clean the contacts with a bit of fine sand paper ? :)

Off Topic mate, but i'm now a MOD too, well on the LOC anyway :D :D

#7 Rikos

Rikos

    Too much time on the boards

  • Budding Enthusiast
  • PipPipPipPip
  • 858 posts
  • Ford Model: Fiesta 1.4 LX

Posted 09 October 2008 - 01:14 PM

Congratulations mate

I'll try and have to find these connectors on the windscreen then cheers Chris

#8 Shinysun

Shinysun

    Member

  • New Member
  • PipPip
  • 20 posts
  • Ford Model: '52 Fiesta 1.4 Zetec
  • Location:

Posted 09 October 2008 - 04:01 PM

Right in front of the drivers side about 4 inches across and then there are a few odd lines over the windscreen


Mine's been like this for a couple years at least, I figured it was burnt out elements (they are so thin!) and that the only fix was a new windscreen and I'm not gonna pay for that!

Let us know if you do manage to fix it cos the stripey clearing bugs me no end!

#9 Rikos

Rikos

    Too much time on the boards

  • Budding Enthusiast
  • PipPipPipPip
  • 858 posts
  • Ford Model: Fiesta 1.4 LX

Posted 10 October 2008 - 08:21 AM

If your fully comp then your windscreen excess will only be 50 ...... not that i'm suggesting anything.

#10 Shinysun

Shinysun

    Member

  • New Member
  • PipPip
  • 20 posts
  • Ford Model: '52 Fiesta 1.4 Zetec
  • Location:

Posted 10 October 2008 - 01:53 PM

If your fully comp then your windscreen excess will only be 50 ...... not that i'm suggesting anything.


Hahaha, I don't know what you mean. ;)

After what my car's been through recently (see updated catalytic woes thread) I'm not gonna be hurling a brick at it!

#11 aztecbandit1

aztecbandit1

    Settling In Well

  • New Member
  • PipPipPip
  • 71 posts
  • Ford Model: Nissan Skyline R33 GT-T :-)
  • Location:

Posted 10 October 2008 - 10:20 PM

Congratulations mate

I'll try and have to find these connectors on the windscreen then cheers Chris


Have you had chance to have a look yet Rik? :unsure:

#12 Rikos

Rikos

    Too much time on the boards

  • Budding Enthusiast
  • PipPipPipPip
  • 858 posts
  • Ford Model: Fiesta 1.4 LX

Posted 13 October 2008 - 08:23 AM

I had a quick look but couldnt see anything. Need to have a more in depth look, dont suppose you know roughly where i should be looking?

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users