• 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Join Premium & Save
      Join Premium & Save
    • Share Your Car Experience
      Share Your Car Experience
    • Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members


jarow

Turbo Problems On S Max Diesel ?

3 posts in this topic

I have a 07 diesel manual S-Max (which you have serviced a few times) and was driving back home on Saturday evening when there was a light thud and a whining sound coming from the engine when we needed power - perhaps the turbo / EG connector? The Engine Fault light came on intermittently and the whining subsided when cruising slowly - never went above 2500 rpm. The Ford user manual did not state we should stop the car so we carried on the remaining hour's drive home. Engine temperature stayed normal, no oil pressure light came on and there were no other noises or smells.

I parked the car on arriving. Noticed a small oil spill on the drive in the morning - probably an eggcup's worth of oil. Tried to start the car but starter motor cut out - lights work but the battery may be low as the electric windows seems to struggle to go up and down. Today I inspected the oil level - it is normal and I see no debris in the oil.

I need your guidance - do I:

i) Try to jump start the car so that I can drive it to garage? (should i try pushing the car in 4/5th gear to check the engine turns?; is the starter motor powerful enough to damage the engine if there is a possible hydrolock situation?)

ii) Get it towed - I may struggle with steering and braking?

iii) Resort to getting the car recovered?

Can you give me your advice and comments at the earliest opportunity please?

Share this post


Link to post
Share on other sites
 

to be on the safe side i would just get the car recovered and have the garage give you a courtesy car. Its always better to be safe than sorry

Share this post


Link to post
Share on other sites

to be on the safe side i would just get the car recovered and have the garage give you a courtesy car. Its always better to be safe than sorry

Thanks for the reply. I have since managed to jump start the car and drove it to the garage. It was the air inlet hose working loose and got it fixed for £45. If seemed that the hose clip was corroded etc - though I suspect it may have been knocked when last repaired. I hope this is now the end of the issue.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now