Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


Sign in to follow this  
Followers 0
Frantastic

Fiesta Electrics Gone Crazy

1 post in this topic

I have a fiesta 1.3 mk4 (t reg) which I originally baught to do up as a rally car, but have used as a run about as I have just sold my modded motor, It has run without any issues what so ever for 2 years now but this last week there has been something very wrong with the electrics

)

Ok, so when I turn the ignition on i get the oil, handbrake, battery and airbag lights on (im sure there should be more) the digital milometer flashes all 8's breifly then is off, the petrol gauge and speedometer dont move or work ... after a while they will all start working again, the oil and petrol light comes on and then goes off once its started working again. however the radio doesnt always come back on, I have had it working 2 times out of 16, no lights no anything but it will eject, and I have had it working twice and it does deffo work

I had only experienced the dash problems after starting up until now as once everything was working it would stay working (excluding the radio which is a sony xplod aftermarket radio) but today everything cut out (apart from the engine ???) at 70 in the 3rd lane of the motorway (scary) so I really need to try and get this sorted but I'll be honest it is pickling me,

Any ideas or info much appreciated :)

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0