Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
Anty88

Problem With '96 Fiesta 1.25 LX Zetec 16v

2 posts in this topic

My fiesta still runs fine, keeps cool, and starts first time everytime. But When it starts it makes a high pitched squeak sound and this sound stays with me until i reach my destination and turn the engine off. Sounds like the fan/cambelt ? If i spray the belt that runs along the left side of the engine with WD-40, the sound will go away for a bit. Then come back later on and stay until i respray. Does anyone have an idea of what this is and how much it would set me back to get fixed up ?

Cheers :)

Share this post


Link to post
Share on other sites
 

it sounds like the belt is starting to become hard, in the old days we would use belt dressing fluid but nowadays it just as cheap to replace the belt. sugest you take the belt off and check for any tight bearings that could also be noisy as well

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0