Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
TREY

1.8 Lx Poblems

1 post in this topic

Hi guys. Can anyone help me? I tried to do MOT's and I had these failures 7.3.D.2c ( exhaust emissions carbon monox. content at idle excessive)... 7.3.2(exhaust emissions carbon monoxidecontent after2nd fast idle excessive)...7.2.D.2b(ex emiss. hydrocarbon content after 2nd fast idle excessive)...7.3.D.2b( exh. emiss. lambda reading after 2nd fast idle outside specified limits) 7.3.A.1c (exh. emits excessive dense blue smoke during acceleration). those from the garage told me it's the EGR valve and oxygen sensor. but after I changed them one day ago, surprise, today the board light reappeared. someone can tell me why????????I must say that after I changed, everything was ok. but today the engine started to stop, and I ended the day with the same light on board, as yesterday. this means money and work for nothing?

Cheers, John.

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0