Jump to content


Photo

Useing Excessive Water


  • Please log in to reply
2 replies to this topic

#1 dancman

dancman

    Newbie

  • New Member
  • Pip
  • 7 posts
  • Ford Model: 1997 fiesta ghia

Posted 06 February 2011 - 11:27 AM

Hi guys
i have just got my mk4 fiesta ghia zetec s back from having an engine fitted and she is running great apart from useing excessive water in fact she was bone dry after a 25 mile trip can any help me?

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 calmcdermott

calmcdermott

    Area Rep: Northeast

  • True Ford Enthusiast
  • PipPipPipPip
  • 579 posts
  • Name: Callum
  • Ford Model: Ford Fiesta ST500
  • Year: 2008
  • Location: Yorkshire

Posted 06 February 2011 - 02:51 PM

Hi, I would check your water pipes ro ensure there are no leaks otherwise I would say the only reason why it would be using water is that the headgaskett will be on its way out.

#3 dancman

dancman

    Newbie

  • New Member
  • Pip
  • 7 posts
  • Ford Model: 1997 fiesta ghia

Posted 06 February 2011 - 04:01 PM

[/quote]
hi
i have found a considerable leak in one of the pipes so will change it. do you think i have done any damage driving the 20 odd miles with no water the weather was cold last night and did not go over 50 much.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users