Jump to content


Photo

Greetings From Malta!


  • Please log in to reply
3 replies to this topic

#1 FordFocus1.8tdci

FordFocus1.8tdci

    Member

  • New Member
  • PipPip
  • 15 posts
  • Ford Model: Focus 1.8TDCI

Posted 06 February 2011 - 05:49 PM

Greetings from Malta to all of you! I've only been a Ford owner since last September but already experiencing a problem on my 57 reg. Focus 1.8 TDCI. I posted the problem on the Focus owner forum whilst keeping my fingers crossed and hoping that someone could help me! Thanks and regards!

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 jmurray01

jmurray01

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 794 posts
  • Name: Jamie
  • Ford Model: None at present
  • Year: Non
  • Location: Moray

Posted 06 February 2011 - 06:42 PM

Welcome to the Ford-Owners-Club! B)

#3 fordpartsman

fordpartsman

    Area Rep: Midlands

  • Super Mod
  • 536 posts
  • Name: Adam
  • Ford Model: Fiesta MK7 Zetec S 1.6 Tdci
  • Year: 2010
  • Location: Northamptonshire

Posted 06 February 2011 - 06:49 PM

welcome to FOC :)

#4 Gazjs

Gazjs

    Area Rep: Central and North Scotland (Detailing Obsessive)

  • New Member
  • PipPipPipPipPip
  • 2,873 posts
  • Ford Model: Fiesta Mk 6 Facelift
  • Location:

Posted 07 February 2011 - 11:00 AM

Welcome :)


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users