Jump to content


Photo

Knocking Since New Front Spring


  • Please log in to reply
1 reply to this topic

#1 andymanhole780

andymanhole780

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: Ka

Posted 06 February 2011 - 08:26 PM

Hi

My car failed it's MOT on a front left spring. They popped a new one on and everytime i go over a spead bump the front left knocks now. Twice is knocks. Once entering the ramp and once after.

Can anyone advise me further? I can not see anything catching or anything.

Thanks

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 stef123

stef123

    Ford Enthusiast

  • Management
  • 5,866 posts
  • Name: Stefan
  • Ford Model: Mondeo ST TDCI
  • Year: 2006
  • Location: Scotland
Contributor

Posted 06 February 2011 - 09:24 PM

Hi

My car failed it's MOT on a front left spring. They popped a new one on and everytime i go over a spead bump the front left knocks now. Twice is knocks. Once entering the ramp and once after.

Can anyone advise me further? I can not see anything catching or anything.

Thanks


theres a few things it could be, an incorrectly fitted spring or perhaps the anti roll bar drop link.

I would be taking the car back to who ever fitted the spring and telling them to look at it.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users