Jump to content


Show
Photo

Streetka Luxury 54 plate Overheating


  • Please log in to reply
3 replies to this topic

#1 hammysandwich

hammysandwich

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: Streetka Luxury
  • Location:

Posted 17 October 2008 - 11:39 AM

My streetka started overheating on the way home from the gym last night :angry:

I topped up with coolant and water combo but its still happening. The fan is working overtime and its doing my head in!

Does anyone know what it could be (I'm thinking possibly thermostat) and how I can fix it? - simple terms please I am a girl who does not really have much of a clue! :blink:

Thanks

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,464 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 20 October 2008 - 02:57 PM

could be the thermostat or your water pump not working

#3 Nutjob

Nutjob

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Streetka
  • Location:

Posted 19 November 2008 - 12:15 PM

Hi
Did you get this sorted. My Streetka 04 plate is doing the same... I was intially told it was a leaking radiator cap. But the problems of overheating continued now i am told now i need a new thermostat and water pump - bur ford are saying there many more proplems.

How did you get on?

#4 DELRIO

DELRIO

    Member

  • Budding Enthusiast
  • PipPip
  • 18 posts
  • Name: del
  • Ford Model: street ka
  • Year: 2004
  • Location: London

Posted 12 September 2011 - 05:09 PM

Hi
Did you get this sorted. My Streetka 04 plate is doing the same... I was intially told it was a leaking radiator cap. But the problems of overheating continued now i am told now i need a new thermostat and water pump - bur ford are saying there many more proplems.

How did you get on?


yep I am in the same boat! and i think it is the water pump or belt that drives it as there is a squeaking coming from that area and im not losing any coolant. also an AA guy tested the expansion tank lid and head gasket and said they are fine.

is the water pump/belt gonna be a costly job???

cheers,

DEL


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users