Jump to content


Weird Electrical Fault

  • Please log in to reply
No replies to this topic

#1 mondeoroy



  • New Member
  • Pip
  • 1 posts
  • Ford Model: Mondeo

Posted 15 February 2011 - 11:29 PM

Hi all
Hopefully (as a newbie) I've found the right home for my question. Apologies if I'm in the wrong place.

I have a 2001 Mondeo that has developed an electrical fault that is proving hard to nail because it will only happen once every 2 or 3 days. While driving around the interior light will suddenly come on and a half-second later all the lights on dashboard go out and the dials (speedo, temp, fuel etc.) all go to zero. The background light to the dash board remains on, the car headlights stay on and the engine still functions normally. After 5 seconds everything returns to normal. This has been going on now for 2 months or so and doesn’t get any worse or better. Weirdly it seems to happen at almost the same stretch of road every time during my commute.
The garage has “checked it out” using some diagnostics tool, but because the fault wasn’t occurring during the test it failed to advance any understanding. “Bring it back when the fault re-occurs..”.
Any ideas what this could be - any tests I could do?
Many thanks for any help


Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users