Jump to content


Photo

GALAXY 2003 ZETEC DIESEL


  • Please log in to reply
4 replies to this topic

#1 REYNOLDS

REYNOLDS

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Ford Model: GALAXY

Posted 19 October 2008 - 09:54 AM

JUST REPLACED DISCS AND PADS ALL ROUND NOW THE BRAKE PEDAL SOMETIMES FEELS LIKE SERVO NOT WORKING ANY IDEAS HAS IT HAPPENED TO YOU HELP PLEASE

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,465 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 20 October 2008 - 03:20 PM

if the brake clynders were push back to quickly the seals in the master cylnder could have been reversed

#3 REYNOLDS

REYNOLDS

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Ford Model: GALAXY

Posted 25 October 2008 - 08:03 AM

when i put my foot on brake pedal engine running it goes down are they the symtoms of master cylinder problem. help much appreceited

#4 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,465 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 25 October 2008 - 07:11 PM

sounds like fluid is bypassing the seals in the master clynder.

#5 REYNOLDS

REYNOLDS

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Ford Model: GALAXY

Posted 31 October 2008 - 08:29 AM

thanks for your help
brought new master cylinder does anyone know how hard it is to fit it cheers


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users