Jump to content


Photo

Mondeo Mk3 Problems


  • Please log in to reply
No replies to this topic

#1 chris2512

chris2512

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: Mondeo Mk3 Ghia Estate 2001

Posted 19 February 2011 - 11:28 PM

Hi Everyone

Im sure you've heard all these problems before.

Ive recently bought a 2001 Mondeo Estate and I have a few little problems.

1. The windscreen wiper stalk doesn't make a noise when pushing for the front screen to be washed... but if I pull the arm towards me the rear wiper doesn't move ( it makes a pinking sound) and if i "help it" it will go back and forth, but pull the arm one more time to spray the rear window... the front and rear get wet???? any ideas??? Do I need a new motor? do I need a new stalk?

2. As I was driving the other day I wanted to see how cold the aircon went and as I turned the temp down.... the temp gauge on the dash went from the middle (normal setting) to cold??? and it never goes higher than cold now, although the heater does get warm but takes a long time to get warm. Do I need a new thermostat? or a new temp sensor switch??

Thats about it, I would appreciate any help on these matters.

Many thanks in advance

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users