• Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Join Premium & Save
      Join Premium & Save
    • Get Your Club gear
      Get Your Club gear
    • Huge Range of Ford Parts
      Huge Range of Ford Parts

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


samsheriff

56 Galaxy Not Starting

2 posts in this topic

hi my 56reg 2.0d had problems starting managed to get it going after 3rd or so attempt lasted for 2 weeks now cant get it started. garage has had it for two weeks now replaced fuel filter got it going and running fine but parked on hill bonnet side up and now wont start again. They said that fuel seems to be running back to the tank causing air into the fuel pipe. they have run tests but still with no solutions. has anyone got an idea what can causing this before they start replacing the whole fuel system part by part.

Share this post


Link to post
Share on other sites
 

Hi

Did you ever find out what the problem was?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now