Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Kennywhoo

Running Problem Focus 1.8 Tddi

2 posts in this topic

Hello everyone.

I have a focus 1.8 tddi zetec estate on a x reg.

Now the problem: a few weeks ago I was on the m6 doing 80mph when the the speedo shoot round to 120mph then went back to 80mph all fine after that. At the weekend same thing happened again. Now it's doing it on my way to work in the morning.

Now when this happens the engine rev's up but the rev needle stays at 2000rpm. I've done the dashboard trick and there are no DTC codes.

So over to you guys.

Kev.

Share this post


Link to post
Share on other sites
 

Could be an instrument cluster fault, I have read many a time here of the mk1 instrument cluster failing and a recall originally? might be down to this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now