Jump to content


Photo

Passenger Window Problems


  • Please log in to reply
3 replies to this topic

#1 russgabb

russgabb

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Focus

Posted 12 March 2011 - 06:37 PM

Hi folks,

I have been having problems with the passenger side electric window on my 2003 focus. The passenger switch made the window go down fine but was a bit iffy when putting the window up, the switch for the passeneger window on the drivers door worked fine. Today i thought maybe the switch could be fixed so was operating the window by pushing the contacts on the switch with a screwdriver. Unfortunaetly my screwdriver slipped and there was a little spark and now the window does not operate at all from the passenger or drivers door switch. The light on the switch still illuminates if that helps.

Now are there seperate fuses for passenger and driver side windows?
Is it possible i have blown the motor, how would i check this before i search ebay to buy a new one (i have a multimeter, just not sure what to do with it!)

Is there any other things i could check first?

Thanks in advance

Russ

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 btmaldon

btmaldon

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 2,581 posts
  • Name: Bruce
  • Ford Model: BMW 320i Coupe M Sport, KA Luxury
  • Year: 2008
  • Location: Essex

Posted 12 March 2011 - 07:04 PM

Its probably just the fuse, and I would have thought that there was only one.

If the window is getting stuck on the way up, try some sylicon spray down the window channels. If it is the switch that is the problem, it is likely to be the contacts where it plugs into the connector.

#3 russgabb

russgabb

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Focus

Posted 12 March 2011 - 07:30 PM

Thanks for the reply.

If it was 1 fuse both driver and passeneger side would not work though? Drivers window works fine.

Everything was working fine, window was not sticking or jamming, merely the up bit of the switch was temperemental. It was removing the rocker cover on the switch and poking a screwdriver in that appears to have shorted something i.e. i'm thinking the motor but how can i be sure.

The Drivers window still works but passenger side does not respond with either switch on drivers door or passenger door. Its just dead.

Cheers

Russ

#4 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 20,958 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 14 March 2011 - 08:16 AM

Sounds like a wiring issue, I think the focus is one fuse for all windows, but it could be as simple as the switch needs replacing, or it could be more sinister, like the actual cable.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users