Jump to content


Photo

130 Tdci 03 Acceleration Pulse


  • Please log in to reply
4 replies to this topic

#1 Snapper

Snapper

    Settling In Well

  • New Member
  • PipPipPip
  • 43 posts
  • Ford Model: Mondeo tdci 130 Zetec

Posted 18 March 2011 - 09:36 AM

Commuting yesterday and over 2800 rpm in 4,5,6th gears I felt a strange pulsing , it felt like torque was on/off enough to make me aware.
Speedo was climbing steadily as was the Tacho, but there was a definate slow pulsing in torque delivery.
Where do I start looking? Wastegate, EGR?

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,560 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 18 March 2011 - 07:11 PM

i would start with an egr valve cleanout,its a messy job but worth it, this link will help
http://www.fordwiki.co.uk/index.php?title=EGR_Valve_and_Inlet_Manifold_Clearout_TDCi
also check the intercooler hose which is the big hose from the bottom of the egr valve for any splits,and for any splits in the rubber vacume hoses.

#3 Snapper

Snapper

    Settling In Well

  • New Member
  • PipPipPip
  • 43 posts
  • Ford Model: Mondeo tdci 130 Zetec

Posted 19 March 2011 - 02:38 PM

Yep, EGR to intercooler pipe 2" split just where you can't see it.
Saw what looked like a big patch on a near by pipe, air blowing from the split.
Did not have any silicon pipe or joiners in the workshop so had to pay Fords 54 for a 300mm bit of pipe, robbing *##*$DS

#4 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,560 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 19 March 2011 - 03:52 PM

has the new pipe done the trick and stopped the pulsing?

#5 Snapper

Snapper

    Settling In Well

  • New Member
  • PipPipPip
  • 43 posts
  • Ford Model: Mondeo tdci 130 Zetec

Posted 19 March 2011 - 07:32 PM

Will find out tomorrow, finished the job on the car then went down the pub to watch the England Ireland rugby.
For me not a good day and I owe Irish Mick a pint


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users