Jump to content


Show
Photo
- - - - -

lack of power steering


  • Please log in to reply
5 replies to this topic

#1 Godbomb2908

Godbomb2908

    Settling In Well

  • New Member
  • PipPipPip
  • 36 posts
  • Ford Model: fiesta zetec 1.4 ghia x
  • Location: Staffordshire

Posted 02 November 2008 - 04:24 PM

hi guys, im new to the website
glad i've found it
had a problem develop with my p reg 1.4 fiesta zetec (petrol)
one morning the steering just decided to stop, almost like the steering lock was on
managed to get it working after turning the car off then on again
but now its somewhat stiff
defo nothing like the rack or anything as i've checked that over
its gotta be something to do with the power steering
has anyone else had this problem?
any ideas?
please help!!

Ben

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 Russ

Russ

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 293 posts
  • Ford Model: Fiesta 1.4i zetec

Posted 02 November 2008 - 08:10 PM

hi guys, im new to the website
glad i've found it
had a problem develop with my p reg 1.4 fiesta zetec (petrol)
one morning the steering just decided to stop, almost like the steering lock was on
managed to get it working after turning the car off then on again
but now its somewhat stiff
defo nothing like the rack or anything as i've checked that over
its gotta be something to do with the power steering
has anyone else had this problem?
any ideas?
please help!!

Ben


check for leaks in the power stearing unit as it sounds like the units "gone"

#3 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,461 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 02 November 2008 - 09:32 PM

check you fluid level and drivebelt is tight.

#4 Godbomb2908

Godbomb2908

    Settling In Well

  • New Member
  • PipPipPip
  • 36 posts
  • Ford Model: fiesta zetec 1.4 ghia x
  • Location: Staffordshire

Posted 02 November 2008 - 09:52 PM

check you fluid level and drivebelt is tight.


brilliant thanks
erm checked the fluid from the word go and there is loads
no leaks either
but the drivebelt is a different story so will have a look
and keep you posted
thanks

#5 Godbomb2908

Godbomb2908

    Settling In Well

  • New Member
  • PipPipPip
  • 36 posts
  • Ford Model: fiesta zetec 1.4 ghia x
  • Location: Staffordshire

Posted 08 November 2008 - 10:29 PM

well for past reference if anyone looks to this thread for a similar problem
mine has turned out to be a seized brake caliper!
which was unexpected but it happens
hope this may help someone in the future!

#6 Godbomb2908

Godbomb2908

    Settling In Well

  • New Member
  • PipPipPip
  • 36 posts
  • Ford Model: fiesta zetec 1.4 ghia x
  • Location: Staffordshire

Posted 13 November 2008 - 10:21 PM

lol
well spoke too soon
not the brake caliper
still having problems
car is in garage again now
checking it over for problems
so will keep posted just for future reference

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users