Jump to content


Photo

Faulty Dashboard Displays - Connect L200


  • Please log in to reply
1 reply to this topic

#1 SMH13

SMH13

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Ford Model: Tansit Connect L200 Td SWB
  • Location: Lancashire

Posted 29 March 2011 - 04:32 PM

Hello :unsure:

I have a Transit Connect SWB L200 2005.

Recently tha dashboard display : Speed , fuel etc and even the radio have gone wrong !

When driving the speedometer works intemittently - the dial goes crazy ! Bit hairy on the motorway.

Will it be the electrics ?

Ani ideas appreciated - Thank You

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 IceDiesel

IceDiesel

    Member

  • New Member
  • PipPip
  • 13 posts
  • Ford Model: Focus 1.8 TD Di

Posted 30 April 2011 - 10:26 PM

Hello :unsure:

I have a Transit Connect SWB L200 2005.

Recently tha dashboard display : Speed , fuel etc and even the radio have gone wrong !

When driving the speedometer works intemittently - the dial goes crazy ! Bit hairy on the motorway.

Will it be the electrics ?

Ani ideas appreciated - Thank You



Had this with my Focus last year and it is a bit hairy when the speedo goes! The problem with mine was a Ford recognised fault - they had a dodgy batch of instrument panels and my 03 plate was one of them. I googled it then went to my local dealer who, as it was a problem they knew about, charged my 120 to do the job. Took about 3/4 of an hour but the only problem was they couldnt write the mileage to the new dash which meant that about 112k got written off LOL! Hope this helps x


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users