• Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • Huge Range of Ford Parts
      Huge Range of Ford Parts


Sign in to follow this  
Followers 0
ian martin

dashboard starting problems

2 posts in this topic

Please can somebody help me as im about to go mad!!!!!!!!! I have a 2003 1.8 tdci zetec with the usual dashboard problems, but after cleaning the connections and putting it all back together all was great when i turned the ignition on. But when i went to start it for a second everything seemed perfect until the engine cut out after a few seconds, and now whenever i try to start the car with the dashboard connected its a non runner. Disconnect the dash board cluster and the car runs great until you plug it back in and then 2 seconds or so and it stops the engine dead. i thought it was something todo with the immobiliser but i didnt think the cluster affected it? Please can somebody help me????? :angry:

Share this post


Link to post
Share on other sites
 

When the instrument cluster was replaced on our 1.8 Tcdi all the keys had to be re-coded to the car which suggests that the immobiliser is controlled by something in the instrument pack. Unfortunately Haynes don't have any details on this, simply saying the pack is non-serviceable.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0