• 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Join Premium & Save
      Join Premium & Save
    • Get Your Club gear
      Get Your Club gear

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
holfster

Smax 2.0L 07.engine Management Fault

1 post in this topic

hi, my engine management fault light came on and it went into limpb mode (under standable) and then went off when it was re-started this happenend a couple of times but it seemed to be ok when the fault light went off ,i only started to think something was wrong when driving up an incline at 2000rpm it seemed to miss fire but after 2000rpm it seem to pass. this together with my mpg falling to 32mpg is when i took it to the garage and the errors where stored as turbo boost pressure low this fault has been cleared from the ecu so ive just filled up with bp ultimate £95(wth)and im waiting to see if it happens again.any help on this and i would be greatful ,,,thanks

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0