Jump to content


Photo

Fiesta Td Electrical Problem


  • Please log in to reply
4 replies to this topic

#1 Tomo2482

Tomo2482

    Newbie

  • Budding Enthusiast
  • Pip
  • 7 posts
  • Ford Model: Fiesta

Posted 07 April 2011 - 05:02 PM

Hi,
I have a Fiesta TD 2001 and my battery continually drains overnight unless I disconnect the negative lead. I have had a new alternator, recon starter (tested today its fine), and I am on my second battery. If I leave it connected when I turn the key all the lights come on and the speedo needle goes round but no noise or cranking engine. My garage and a auto electrician can find no drain or fault. Can anyone help all help appreciated.

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 dezwez

dezwez

    Dezwez

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 5,365 posts
  • Name: Derek
  • Ford Model: ford focus 1.8 zetec mk 2.5
  • Year: 2008
  • Location: Cambridgeshire

Posted 07 April 2011 - 05:10 PM

Hi,
I have a Fiesta TD 2001 and my battery continually drains overnight unless I disconnect the negative lead. I have had a new alternator, recon starter (tested today its fine), and I am on my second battery. If I leave it connected when I turn the key all the lights come on and the speedo needle goes round but no noise or cranking engine. My garage and a auto electrician can find no drain or fault. Can anyone help all help appreciated.

hi mate this link might help
you did me link :)

#3 Tomo2482

Tomo2482

    Newbie

  • Budding Enthusiast
  • Pip
  • 7 posts
  • Ford Model: Fiesta

Posted 17 April 2011 - 11:42 AM

hi mate this link might help
you did me link :)


Thanks for that I will have a look !!!!!!!

#4 Tomo2482

Tomo2482

    Newbie

  • Budding Enthusiast
  • Pip
  • 7 posts
  • Ford Model: Fiesta

Posted 17 April 2011 - 11:53 AM

hi mate this link might help
you did me link :)


Just tried my small 12v tester and only thing drawing a small amount of power is the clock its on all the time so I have disconnected it will see if it starts in the morning !!!!!

#5 Tomo2482

Tomo2482

    Newbie

  • Budding Enthusiast
  • Pip
  • 7 posts
  • Ford Model: Fiesta

Posted 01 May 2011 - 08:15 AM

Just tried my small 12v tester and only thing drawing a small amount of power is the clock its on all the time so I have disconnected it will see if it starts in the morning !!!!!


Just disconnected 3 amp violet ecu fuse in engine bay and drain has gone down from 3 amp to 1.3 amp car starts and drives fine ? confused ????


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users