Jump to content


Photo

Engine Management Light


  • Please log in to reply
3 replies to this topic

#1 amanda

amanda

    Member

  • New Member
  • PipPip
  • 15 posts
  • Ford Model: streetka

Posted 09 April 2011 - 08:13 PM

hi, can anyone help me, my car is due for mot on monday and the engine managment light came on this morning, i have taken it to a garage to reset it and read the code. it read code P1322 he asked if i recently had any power problems i said yes i have had a new alternator nearly a month ago. so he reset it to see if i would still get a fault. about 4 hours later the light has come back on. the car drives fine but im not sure what i need to be checking and worried about my mot on monday. please can anyone help?

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 amanda

amanda

    Member

  • New Member
  • PipPip
  • 15 posts
  • Ford Model: streetka

Posted 09 April 2011 - 09:07 PM

sorry the code was 1622

#3 jig

jig

    Member

  • New Member
  • PipPip
  • 20 posts
  • Ford Model: Focus 1.6 TDCI
  • Location: London

Posted 10 April 2011 - 06:22 AM

sorry the code was 1622


Code 1622:immobilizer id does not match

#4 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,551 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 10 April 2011 - 07:45 AM

it could be a wire or connection that has worked loose from when the alternator was fitted, check all the battery and alternator fittings to see if they are all tight,also try recycleing the ignition 3-5 times, making an attempt to start the vehicle each key cycle.this can sometimes reset the immobilize system.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users