Jump to content



  • Please log in to reply
2 replies to this topic

#1 Hutcho



  • New Member
  • Pip
  • 3 posts
  • Ford Model: Galaxy GLX
  • Location:

Posted 13 November 2008 - 06:35 PM

Just curious if anyone else has had this problem or a similar one:

Everytime I stop in traffic, whether it is to stop at traffic lights, in a traffic jam or even a roundabout the cooling fan kicks in and stays running for the duration of my journey, (long or short), I've also noticed that the temp gauge on the dash doesn't move anymore, (the two maybe connected). I've checked water levels etc, everything seems ok. I have spoke to a ford mechanic, he had never heard of this fault before.............

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin


    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,573 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 14 November 2008 - 09:14 AM

sounds like you could have a dodgy temp sender.

#3 delboy


    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 592 posts
  • Name: martin
  • Ford Model: c-max ghia 1.8 petrol /ka 1.2 mk2
  • Year: 2004
  • Location: Somerset

Posted 10 December 2008 - 06:49 AM

hi m8

try the following as i had the same problem

open bonnett & on the rh side there is a large pipe with a connector attatched to it
it comes of the top of the rad the pipe does m8

remove the wires & fit them on the lower connector on the thermostat housing
swap them over as they are the same connectors
mine was crossed & i had the same happening
one is the fan switch & the other is the thermostat for the needle on the dash

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users