• 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Join Premium & Save
      Join Premium & Save
    • Share Your Car Experience
      Share Your Car Experience


Hutcho

Galaxy

3 posts in this topic

Just curious if anyone else has had this problem or a similar one:

Everytime I stop in traffic, whether it is to stop at traffic lights, in a traffic jam or even a roundabout the cooling fan kicks in and stays running for the duration of my journey, (long or short), I've also noticed that the temp gauge on the dash doesn't move anymore, (the two maybe connected). I've checked water levels etc, everything seems ok. I have spoke to a ford mechanic, he had never heard of this fault before.............

Share this post


Link to post
Share on other sites
 

sounds like you could have a dodgy temp sender.

Share this post


Link to post
Share on other sites

hi m8

try the following as i had the same problem

open bonnett & on the rh side there is a large pipe with a connector attatched to it

it comes of the top of the rad the pipe does m8

remove the wires & fit them on the lower connector on the thermostat housing

swap them over as they are the same connectors

mine was crossed & i had the same happening

one is the fan switch & the other is the thermostat for the needle on the dash

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now