Jump to content


Photo

1998 Escort Abs Problem. Need Help.


  • Please log in to reply
No replies to this topic

#1 98escortwagon

98escortwagon

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: 1998 Escort Wagon

Posted 19 April 2011 - 05:07 PM

I have a 1998 escort wagon. The abs started to fire at very low braking speed, right before coming to a stop. Eventually the ABS light came on and disabled the ABS altogether. I took it to the dealer, they said I needed to replace the abs module and that the technician could not even communicate with the abs module. They also found that the carpet was wet on the floor near the ABS module.
- I figured out how the water was entering the car and fixed the leak issue. (not sure if this is related to the ABS communication problem)
- I purchased a used ABS module guaranteed to be working, I unplugged the battery (in an attempt to reset the computer), I plugged in the used module and after a couple spins around the block, the ABS is back to doing the same thing, that is, firing at the very end of coming to a stop.
For now I have resorted to pulling the ABS fuse in the engine compartment to disable it, but I'm looking for some ideas on further troubleshooting this.
Any help would be appreciated!

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users