• Join Premium & Save
      Join Premium & Save
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Share Your Car Experience
      Share Your Car Experience
    • Get Your Club gear
      Get Your Club gear


Sign in to follow this  
Followers 0
davidrp

Rough Idle On A Focus 2005, 1.6 Vct

2 posts in this topic

Hoping someone can help with some advice before I have to pay through the nose. My Focus has re-started a really bad rough idle fault. Essentially, it runs perfectly well, except while stuck in traffic. It intermittently (annoyingly it is not always repeatable) rev's upto about 1200, and down below 800. Sometimes the engine stalls. I had the same problem last summer, the engine management light came on - Oxygen Sensor was responsible. The light then switched itself off, and never came back on.

I switched fuel and the problem disappeared. However, as soon as the weather turned warmer after early spring, the problem has come back again. Any obvious ideas? Is it the oxygen sensor? Would the outside air-temp affect this? Is it likely to damage the CAT?

Any help would be hugely appreciated.

Share this post


Link to post
Share on other sites
 

all i know is that the warmer the air the less oxygen there is in it, so could be oxygen sensor

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0